Internet Explorer 5.X + is needed to print the reports correctly. It will not work with Netscape 3.X or 4.X.